ASP.NET Core 1.0 won’t build on VSTS hosted build agents

Visual Studio Team Services hosted build agents doesn’t seem to have the latest bits onboard.  

I worked hard for a few hours to get a new Core 1,9 project to build using the hosted build agents. I was getting errors like “The dependency Microsoft.AspNetCore.Mvc 1.0.0 does not support framework .NETCoreApp,Version=v1.0.” 

I came across a few blogpost suggesting that you needed to upgrade to the latest dotnet SDK before being able to build, so I thought about querying for versions. I am using the new VSTS build system and added a commandline step: “dotnet –version” to get the tooling version number that reflects the build number of the dotnet sdk bits.

Latest version of the SDK to build 1.0 bits are the 1.0.0-preview2-003121   Earlier version of the sdk to build the Final-RC2 was 002702 … Oh the naming. It has taken me ages to understand just that…

And the dotnet –version returned from the hosted build agent … 1.0.0-preview1-002702 

 

So – SDK tooling for hosted agents on Visual Studio Team Services are not yet ready to build the ASP.NET Core 1.0 bits …

I know … I could just install a local build agent, but why … I am guessing .net core apps are in demand to be build online, so I would hope to get it fixed soon

I have asked @vsteam on twitter when it will be available, but no answer yet.

Thought I’d get the info out there, so others didn’t have to knock heads against walls on this one …

Comments are closed